Deepseadata
Technical User
First I want to paste this great post Burt made (in a closed thread) on how to setup VPN on a router. Then I will start to ask my stupid questions
From Burt:
Basically, you'll want a remote access VPN using IPSEC to encrypt interesting traffic and use pre-shared keys to authenticate...here's my config...
I enabled AAA and instructed the router to use the local username and password to authenticate once connected with these commands
aaa new-model
aaa authentication login my_vpn_xauth local
aaa authorization network my_vpn_group local
aaa session-id common
Then I configure the username, privelege level, and password for local access...
username xxxxxx privilege 15 secret xxxxxxxxx
I then create the isakmp (key management protocol) policy and tell the router what encryption level to use for key exchange, and what Diffie-Hellman group to use
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
I then create the group for authentication, and tell the router what the key is, group name, what IP address pool to use for the client, and netmask. I believe the "include-local-lan" lets me still have access on the client LAN when connected to the remote VPN pool
crypto isakmp client configuration group xxxxxx
key xxxxxxxx
pool vpn_pool_1
include-local-lan
max-users 2
netmask 255.255.255.0
I configure a transform set for IPSEC
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
I create a dynamic map...here's an explanation from Cisco...
"A dynamic crypto map allows you to accept requests for new security associations from previously unknown peers. (However, these requests are not processed until the Internet Key Exchange authentication has completed successfully.)"
crypto dynamic-map vpn_dynmap_1 1
set transform-set ESP-3DES-SHA
reverse-route
I create a map to be applied to the outgoing interface (incoming in the case of a VPN server)...these parameters are associated with the AAA login commands...
crypto map vpn_cmap_1 client authentication list my_vpn_xauth
crypto map vpn_cmap_1 isakmp authorization list my_vpn_group
crypto map vpn_cmap_1 client configuration address respond
crypto map vpn_cmap_1 65535 ipsec-isakmp dynamic vpn_dynmap_1
I apply this crypto map to my outgoing interface...
interface Dialer0
crypto map vpn_cmap_1 I create the local pool that will be assigned to the client once authenticated. In my case, I have my pool configured in the same pool as my LAN on the VPN server, but I exclude these addresses (VPN addresses) from being NATted back out...
ip local pool vpn_pool_1 10.69.69.69 10.69.69.70
then to exclude them in the NAT acl...
access-list 101 deny ip any 10.69.69.68 0.0.0.3
access-list 101 permit ip 10.69.69.0 0.0.0.255 any
As you can see, my LAN is 10.69.69.0/24, and the VPN addresses that will be configured on the remote client are in the same pool---acl 101 denies the two addresses from being NATted and allows all others in the range to be NATted so that my local LAN still has access to the internet. Then I create a route-map and point it to acl 101, and make the NAT inside source this route-map...
I create the route-map and associate acl 101 with it...
route-map vpn_routemap_1 permit 1
match ip address 101
The last thing in the router is to make the NAT statement...
ip nat inside source route-map vpn_routemap_1 interface Dialer0 overload
Now there's the client configuration on the remote machine. Open the client, click new, and give the connection a name, description, and host address. Mine is adsl, so I give it a dns name as configured on dyndns.org. Choose group authentication---name is the group name, and password is the key. Leave everything else at the defaults, and click save. Then you double click the named connection, and it should connect, provided a firewall doesn't block you. Once it connects to the router, it will prompt you for a username and password. The username and password are from what you configured in the router with this command...
username xxxx priv 15 secret xxxxx
Good luck.
Burt
____________________________________________
Now it's time for Deepseadata to ask some dumb ones:
Is this the setup for the server side? I was following you intil we got to the incoming/outgoing interfaces.
The reason I ask is I will need to setup, at least, one client that will do remote maintenance on multiple vLANs. And internet access for testing reasons.
Will this config do that?
Because I'm very new to VPN's, I used SDM to do to setup my easyVPN server then studied the CLI cmmands it sent to the router.
It keeps modifying my NAT entries. I think NAT is going to be the major hurdle with this task isn't it?
From Burt:
Basically, you'll want a remote access VPN using IPSEC to encrypt interesting traffic and use pre-shared keys to authenticate...here's my config...
I enabled AAA and instructed the router to use the local username and password to authenticate once connected with these commands
aaa new-model
aaa authentication login my_vpn_xauth local
aaa authorization network my_vpn_group local
aaa session-id common
Then I configure the username, privelege level, and password for local access...
username xxxxxx privilege 15 secret xxxxxxxxx
I then create the isakmp (key management protocol) policy and tell the router what encryption level to use for key exchange, and what Diffie-Hellman group to use
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
I then create the group for authentication, and tell the router what the key is, group name, what IP address pool to use for the client, and netmask. I believe the "include-local-lan" lets me still have access on the client LAN when connected to the remote VPN pool
crypto isakmp client configuration group xxxxxx
key xxxxxxxx
pool vpn_pool_1
include-local-lan
max-users 2
netmask 255.255.255.0
I configure a transform set for IPSEC
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
I create a dynamic map...here's an explanation from Cisco...
"A dynamic crypto map allows you to accept requests for new security associations from previously unknown peers. (However, these requests are not processed until the Internet Key Exchange authentication has completed successfully.)"
crypto dynamic-map vpn_dynmap_1 1
set transform-set ESP-3DES-SHA
reverse-route
I create a map to be applied to the outgoing interface (incoming in the case of a VPN server)...these parameters are associated with the AAA login commands...
crypto map vpn_cmap_1 client authentication list my_vpn_xauth
crypto map vpn_cmap_1 isakmp authorization list my_vpn_group
crypto map vpn_cmap_1 client configuration address respond
crypto map vpn_cmap_1 65535 ipsec-isakmp dynamic vpn_dynmap_1
I apply this crypto map to my outgoing interface...
interface Dialer0
crypto map vpn_cmap_1 I create the local pool that will be assigned to the client once authenticated. In my case, I have my pool configured in the same pool as my LAN on the VPN server, but I exclude these addresses (VPN addresses) from being NATted back out...
ip local pool vpn_pool_1 10.69.69.69 10.69.69.70
then to exclude them in the NAT acl...
access-list 101 deny ip any 10.69.69.68 0.0.0.3
access-list 101 permit ip 10.69.69.0 0.0.0.255 any
As you can see, my LAN is 10.69.69.0/24, and the VPN addresses that will be configured on the remote client are in the same pool---acl 101 denies the two addresses from being NATted and allows all others in the range to be NATted so that my local LAN still has access to the internet. Then I create a route-map and point it to acl 101, and make the NAT inside source this route-map...
I create the route-map and associate acl 101 with it...
route-map vpn_routemap_1 permit 1
match ip address 101
The last thing in the router is to make the NAT statement...
ip nat inside source route-map vpn_routemap_1 interface Dialer0 overload
Now there's the client configuration on the remote machine. Open the client, click new, and give the connection a name, description, and host address. Mine is adsl, so I give it a dns name as configured on dyndns.org. Choose group authentication---name is the group name, and password is the key. Leave everything else at the defaults, and click save. Then you double click the named connection, and it should connect, provided a firewall doesn't block you. Once it connects to the router, it will prompt you for a username and password. The username and password are from what you configured in the router with this command...
username xxxx priv 15 secret xxxxx
Good luck.
Burt
____________________________________________
Now it's time for Deepseadata to ask some dumb ones:
Is this the setup for the server side? I was following you intil we got to the incoming/outgoing interfaces.
The reason I ask is I will need to setup, at least, one client that will do remote maintenance on multiple vLANs. And internet access for testing reasons.
Will this config do that?
Because I'm very new to VPN's, I used SDM to do to setup my easyVPN server then studied the CLI cmmands it sent to the router.
It keeps modifying my NAT entries. I think NAT is going to be the major hurdle with this task isn't it?