Here is the problem. I have set up a 2509RJ as a PPP dialin server. Everything seems ok, but the remote user can't get a connection to the network. Now here is the odd part, I can ping the remote computer and browse its webserver. It seems like I have a reverse firewall, where I can get in but I can't get out.
Here is the Configuration:
!
version 11.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname AccessServer
!
enable secret 5 ilostmypassword
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
description connected to EthernetLAN
ip address xxx.xxx.198.95 255.255.255.0
no logging event subif-link-status
no keepalive
!
interface Serial0
no ip address
no logging event subif-link-status
shutdown
!
interface Group-Async1
ip unnumbered Ethernet0
encapsulation ppp
no logging event subif-link-status
async mode dedicated
peer default ip address pool Cisco2509-Group-1
no cdp enable
ppp authentication chap
group-range 1 8
!
ip local pool Cisco2509-Group-1 xxx.xxx.198.114 165.2.198.121
ip default-gateway xxx.xxx.198.1
ip classless
ip route 0.0.0.0 0.0.0.0 xxx.xxx.198.1
!
line con 0
exec-timeout 0 0
password xxxxx
login local
line 1 8
autoselect during-login
autoselect ppp
login local
modem InOut
modem autoconfigure discovery
transport input all
stopbits 1
speed 38400
flowcontrol hardware
line aux 0
line vty 0 4
password xxxxx
login
!
end
Here is the Configuration:
!
version 11.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname AccessServer
!
enable secret 5 ilostmypassword
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
description connected to EthernetLAN
ip address xxx.xxx.198.95 255.255.255.0
no logging event subif-link-status
no keepalive
!
interface Serial0
no ip address
no logging event subif-link-status
shutdown
!
interface Group-Async1
ip unnumbered Ethernet0
encapsulation ppp
no logging event subif-link-status
async mode dedicated
peer default ip address pool Cisco2509-Group-1
no cdp enable
ppp authentication chap
group-range 1 8
!
ip local pool Cisco2509-Group-1 xxx.xxx.198.114 165.2.198.121
ip default-gateway xxx.xxx.198.1
ip classless
ip route 0.0.0.0 0.0.0.0 xxx.xxx.198.1
!
line con 0
exec-timeout 0 0
password xxxxx
login local
line 1 8
autoselect during-login
autoselect ppp
login local
modem InOut
modem autoconfigure discovery
transport input all
stopbits 1
speed 38400
flowcontrol hardware
line aux 0
line vty 0 4
password xxxxx
login
!
end