Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Mike Lewis on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Load-balanced multihomed router routing problem

Status
Not open for further replies.

justin12345

Technical User
Jul 21, 2008
10
US
I have 4 DSL lines attached to a Cisco 2811. 2 of them have been installed and working fine. I've recently turned up 2 more but both of them have the same connected route.

The problem is that if I add:
'ip route 0.0.0.0 0.0.0.0 3.3.3.3' then one of the DSL lines won't carry any traffic since it is the same connected route.

It may be a separate issue, but when I use the interface name instead of next-hop router I get very poor system performance so that doesn't seem to be an option.

Here's the config and "show ip route" output:

hostname Sitka2811
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.10
ip dhcp excluded-address 192.168.1.245 192.168.1.254
!
ip dhcp pool everyone
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 4.2.2.2 4.2.2.1
lease 7
!
!
no ip domain lookup
ip domain name yourdomain.com
vpdn enable

interface Loopback0
ip address 192.168.2.1 255.255.255.0
!

interface FastEthernet0/0
ip address 10.0.1.10 255.255.255.0 secondary
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
priority-group 2
!
interface FastEthernet0/1
ip address 192.168.5.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface ATM0/0/0
no ip address
no ip mroute-cache
atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
pvc 0/32
encapsulation aal5mux ppp dialer
dialer pool-member 3
!
!
interface ATM0/1/0
no ip address
no ip mroute-cache
atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
pvc 0/32
encapsulation aal5mux ppp dialer
dialer pool-member 4
!
!
interface ATM0/2/0
no ip address
no ip mroute-cache
atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
pvc 0/32
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface ATM0/3/0
no ip address
no ip mroute-cache
atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
pvc 0/32
encapsulation aal5mux ppp dialer
dialer pool-member 2
!
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
random-detect
random-detect flow
random-detect flow count 16
ppp authentication pap chap callin
ppp chap hostname username
ppp chap password 0 mypassword
ppp pap sent-username username password 0 mypassword
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 2
dialer-group 2
random-detect
random-detect flow
random-detect flow count 16
ppp authentication pap chap callin
ppp chap hostname username
ppp chap password 0 mypassword
ppp pap sent-username username password 0 mypassword
!
interface Dialer2
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 4
dialer-group 4
random-detect
random-detect flow
random-detect flow count 16
ppp authentication pap chap callin
ppp chap hostname username
ppp chap password 0 mypassword
ppp pap sent-username username password 0 mypassword
!
interface Dialer3
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 3
dialer-group 3
random-detect
random-detect flow
random-detect flow count 16
ppp authentication pap chap callin
ppp chap hostname username
ppp chap password 0 mypassword
ppp pap sent-username username password 0 mypassword
!
ip classless
ip route 0.0.0.0 0.0.0.0 1.1.1.1
ip route 0.0.0.0 0.0.0.0 2.2.2.2
ip flow-export source FastEthernet0/0
ip flow-export version 5
ip flow-export destination 192.168.1.245 9996
!
no ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source route-map NATdailer2 interface Dialer2 overload
ip nat inside source static tcp 192.168.1.245 3389 interface Dialer1 3389
ip nat inside source static tcp 192.168.1.245 8080 interface Dialer1 8080
ip nat inside source route-map NATdailer0 interface Dialer0 overload
ip nat inside source route-map NATdailer1 interface Dialer1 overload
ip nat inside source route-map NATdailer3 interface Dialer3 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 permit icmp any any
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
priority-list 1 protocol http high
priority-list 1 protocol ip medium tcp smtp
priority-list 1 protocol ip medium tcp pop2
priority-list 1 protocol ip medium tcp pop3
priority-list 1 default low
priority-list 2 protocol http high lt 1000

route-map NATdailer0 permit 10
match ip address 1
match interface Dialer0
!
route-map NATdailer1 permit 10
match ip address 1
match interface Dialer1
!
route-map NATdailer2 permit 10
match ip address 1
match interface Dialer2
!
route-map NATdailer3 permit 10
match ip address 1
match interface Dialer3
!
!
!
control-plane
!
!
banner login ^CRestricted Access. Authorized Users Only!^C
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

Sitka2811#
Sitka2811#
Sitka2811#
Sitka2811#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 1.1.1.1 to network 0.0.0.0

207.225.84.0/32 is subnetted, 3 subnets
C 1.1.1.1 is directly connected, Dialer1
C 3.3.3.3 is directly connected, Dialer3
is directly connected, Dialer2
C 2.2.2.2 is directly connected, Dialer0
65.0.0.0/32 is subnetted, 2 subnets
C 3.3.3.4 is directly connected, Dialer2
C 3.3.3.5 is directly connected, Dialer3
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.1.0 is directly connected, FastEthernet0/0
63.0.0.0/32 is subnetted, 2 subnets
C 2.2.2.3 is directly connected, Dialer0
C 1.1.1.2 is directly connected, Dialer1
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [1/0] via 1.1.1.1
[1/0] via 2.2.2.2
Sitka2811#
 
The way to get around the issues with the connected routes is to offload nat to another device. We have used old pix firewalls for this before, but any old d-link or linksys will work. The idea is to make the next hop out of the new interfaces go to different IP addresses.

|-------- ISP1
|-------- ISP2
-----Router |--------PIX----ISP3
|--------PIX----ISP4

Shawn
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top