I am setting up an 1841 cisco router to browse the internet, but not using the serial connection, only using the FE connection. I have been tweaking a config, but the closest I have come to so far is being able to ping the router IP from the outside and ping the native Vlan IP from the inside. Can someone look at my config and let me know what needs to be changed/ where I went wrong.
interface FastEthernet0/0
description connected to $ETH-LAN$
ip address 173.?.?.125 255.255.?.?
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description Physical interface connection
no ip address
no ip split-horizon
duplex auto
speed auto
!
interface FastEthernet0/1.1
description LocalLan-Vlan1
encapsulation dot1Q 1 native
ip address 172.16.1.? 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.5
description Storage-Vlan5
encapsulation dot1Q 5
ip address 172.16.5.? 255.255.255.0
ip helper-address 172.16.?.?
ip nat inside
ip virtual-reassembly
interface Serial0/0/0
no ip address
shutdown
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 173.?.?.130
ip http server
ip nat inside source list 10 interface FastEthernet0/0 overload
ip nat inside source static tcp ?.?.?.? ****0 interface FastEthernet0/0 ****0
ip nat inside source static tcp ?.?.?.? **** interface FastEthernet0/0 ****
ip nat inside source static tcp ?.?.?.? **** interface FastEthernet0/0 ****
ip nat inside source static tcp ?.?.?.? ****interface FastEthernet0/0 ****
ip nat inside source static tcp ?.?.?.? ???? interface FastEthernet0/0 ????
ip nat inside source static tcp ?.?.?.? ????6 interface FastEthernet0/0 ****
ip nat inside source static tcp ?.?.?.? **** interface FastEthernet0/0 ****
ip nat inside source static ?.?.?.? 173.?.?.?
access-list 10 permit 172.16.1.0 0.0.0.255
access-list 10 permit 172.16.5.0 0.0.0.255
access-list 99 permit 172.16.5.0 0.0.0.255 log
access-list 99 permit ?.?.?.? 0.0.0.255 log
access-list 99 permit 172.16.1.0 0.0.0.255 log
access-list 99 permit ?.?.?.? 0.0.0.7 log
access-list 99 permit ?.?.?.? 0.0.0.7 log
access-list 99 permit ?.?.?.? 0.0.0.7 log
access-list 99 permit ?.?.?.? 0.0.0.255 log
access-list 99 deny any log
access-list 102 permit icmp any any
access-list 110 remark SDM_ACL Category=16
access-list 110 permit ip host 173.?.?.? host 69.?.?.?
access-list 110 remark SDM_ACL Category=16
interface FastEthernet0/0
description connected to $ETH-LAN$
ip address 173.?.?.125 255.255.?.?
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description Physical interface connection
no ip address
no ip split-horizon
duplex auto
speed auto
!
interface FastEthernet0/1.1
description LocalLan-Vlan1
encapsulation dot1Q 1 native
ip address 172.16.1.? 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.5
description Storage-Vlan5
encapsulation dot1Q 5
ip address 172.16.5.? 255.255.255.0
ip helper-address 172.16.?.?
ip nat inside
ip virtual-reassembly
interface Serial0/0/0
no ip address
shutdown
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 173.?.?.130
ip http server
ip nat inside source list 10 interface FastEthernet0/0 overload
ip nat inside source static tcp ?.?.?.? ****0 interface FastEthernet0/0 ****0
ip nat inside source static tcp ?.?.?.? **** interface FastEthernet0/0 ****
ip nat inside source static tcp ?.?.?.? **** interface FastEthernet0/0 ****
ip nat inside source static tcp ?.?.?.? ****interface FastEthernet0/0 ****
ip nat inside source static tcp ?.?.?.? ???? interface FastEthernet0/0 ????
ip nat inside source static tcp ?.?.?.? ????6 interface FastEthernet0/0 ****
ip nat inside source static tcp ?.?.?.? **** interface FastEthernet0/0 ****
ip nat inside source static ?.?.?.? 173.?.?.?
access-list 10 permit 172.16.1.0 0.0.0.255
access-list 10 permit 172.16.5.0 0.0.0.255
access-list 99 permit 172.16.5.0 0.0.0.255 log
access-list 99 permit ?.?.?.? 0.0.0.255 log
access-list 99 permit 172.16.1.0 0.0.0.255 log
access-list 99 permit ?.?.?.? 0.0.0.7 log
access-list 99 permit ?.?.?.? 0.0.0.7 log
access-list 99 permit ?.?.?.? 0.0.0.7 log
access-list 99 permit ?.?.?.? 0.0.0.255 log
access-list 99 deny any log
access-list 102 permit icmp any any
access-list 110 remark SDM_ACL Category=16
access-list 110 permit ip host 173.?.?.? host 69.?.?.?
access-list 110 remark SDM_ACL Category=16