Hi, I have a Cisco 831 and I am fairly new with configuring cisco routers. What I have is
Internet>>>Modem>>>Router>>>Switch>>Computers
What I want to do is have the Router hand out IP's through DHCP
Heres my config
Building configuration...
Current configuration : 1306 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
no ip dhcp use vrf connected
!
ip dhcp pool my_pool
network 12.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 24.226.1.93 24.226.10.193 24.226.1.94 24.226.10.194
!
!
ip cef
!
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Ethernet1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
!
interface Ethernet2
no ip address
shutdown
!
interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 Ethernet1
!
no ip http server
no ip http secure-server
!
ip nat inside source list 117 interface Ethernet1 overload
!
access-list 103 deny ip 10.0.0.0 0.255.255.255 any log
access-list 103 deny ip 172.16.0.0 0.15.255.255 any log
access-list 117 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
control-plane
!
!
line con 0
no modem enable
speed 115200
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end
Internet>>>Modem>>>Router>>>Switch>>Computers
What I want to do is have the Router hand out IP's through DHCP
Heres my config
Building configuration...
Current configuration : 1306 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
no ip dhcp use vrf connected
!
ip dhcp pool my_pool
network 12.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 24.226.1.93 24.226.10.193 24.226.1.94 24.226.10.194
!
!
ip cef
!
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Ethernet1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
!
interface Ethernet2
no ip address
shutdown
!
interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 Ethernet1
!
no ip http server
no ip http secure-server
!
ip nat inside source list 117 interface Ethernet1 overload
!
access-list 103 deny ip 10.0.0.0 0.255.255.255 any log
access-list 103 deny ip 172.16.0.0 0.15.255.255 any log
access-list 117 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
control-plane
!
!
line con 0
no modem enable
speed 115200
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end