Hello guys, I'm new to Cisco routers, I've had my first one for 5 days, and for 5 days I've been trying to configure it to work with my cable internet (Comcast). I'm currently using a netgear fvs318, but I want to replace the netgearfs router with this cisco 831 I got off ebay. Eventually I'll get something newer like a 85x or 87x. Basically I want to be able to and feel safe to open up ports for a db server down the road, but for now I want to at least be able to connect to the internet. Baby steps...
This is my setup now
Internet <--> Cable Modem (motorola) <--> Cisco 831 <--> PCs
I've been online for days trying to make my configuration work but I'm not able to connect to the internet yet. I'm able to get an ip from my ISP along with dns servers, but I cannot get outside my LAN. This is my configuration so far. I know that Cisco is the best way to go when it comes to routing, and I don't want to give up half ways through this. I want to get it to work one way or another.
Well this is the configuration I'm running now:
!
version 12.3
service config
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
memory-size iomem 15
no logging buffered
!
no aaa new-model
ip subnet-zero
!
ip dhcp pool DHCP
import all
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
!
!
ip cef
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
description Internal LAN
ip address 192.168.2.1 255.255.255.0
ip nat inside
!
interface Ethernet1
description Internet$ETH-WAN$
mac-address 0013.207c.e69f
ip address dhcp client-id Ethernet1
ip nat outside
duplex auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
router rip
version 2
network 192.168.2.0
no auto-summary
!
ip nat inside source list 102 interface Ethernet0 overload
ip classless
!
ip http server
no ip http secure-server
!
access-list 102 permit ip 192.168.2.0 0.0.0.255 any
!
line con 0
exec-timeout 120 0
no modem enable
line aux 0
line vty 0 4
exec-timeout 120 0
!
scheduler max-task-time 5000
!
end
I would really appreciate if someone can give me a hand with this. I'm sure that it is something pretty simple, but I just can't pin point it. thanks.
This is my setup now
Internet <--> Cable Modem (motorola) <--> Cisco 831 <--> PCs
I've been online for days trying to make my configuration work but I'm not able to connect to the internet yet. I'm able to get an ip from my ISP along with dns servers, but I cannot get outside my LAN. This is my configuration so far. I know that Cisco is the best way to go when it comes to routing, and I don't want to give up half ways through this. I want to get it to work one way or another.
Well this is the configuration I'm running now:
!
version 12.3
service config
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
memory-size iomem 15
no logging buffered
!
no aaa new-model
ip subnet-zero
!
ip dhcp pool DHCP
import all
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
!
!
ip cef
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
description Internal LAN
ip address 192.168.2.1 255.255.255.0
ip nat inside
!
interface Ethernet1
description Internet$ETH-WAN$
mac-address 0013.207c.e69f
ip address dhcp client-id Ethernet1
ip nat outside
duplex auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
router rip
version 2
network 192.168.2.0
no auto-summary
!
ip nat inside source list 102 interface Ethernet0 overload
ip classless
!
ip http server
no ip http secure-server
!
access-list 102 permit ip 192.168.2.0 0.0.0.255 any
!
line con 0
exec-timeout 120 0
no modem enable
line aux 0
line vty 0 4
exec-timeout 120 0
!
scheduler max-task-time 5000
!
end
I would really appreciate if someone can give me a hand with this. I'm sure that it is something pretty simple, but I just can't pin point it. thanks.