I have commercial DSL service with 5 static addresses. I have been using off-the-shelf LinkSys residential routers with port-forwarding to host some web servers under each of the LinkSys routers. I recently decided to upgrade to a ‘real’ router and bought a used Cisco 2600. I’ll be damned if I can get the routing to work.
All I am trying to do for now is to get a single host on LAN side of the Cisco router to be able to ping the underside of the DSL router. I’m sure there is something simple and stupid I am doing wrong. Here are the details (some leading octets altered in the name of security):
DSL Modem LAN-side (gateway) address: 167.127.130.158
I have addresses 153-157
Here is my running-config. There is a PC sitting at 10.0.0.6 that can ping 10.0.0.1 and 167.127.130.157 but not the next hop (DSL router) at 167.127.130.158 or anything else on the internet. From the router I can ping 167.127.130.158 or anything else on the internet and I can also telnet to the router over the internet.
interface FastEthernet0/0
ip address 167.127.130.157 255.255.255.248
no ip mroute-cache
speed auto
full-duplex
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.0
no ip mroute-cache
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 167.127.130.158
ip route 10.0.0.0 255.255.255.0 FastEthernet0/0
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
All I am trying to do for now is to get a single host on LAN side of the Cisco router to be able to ping the underside of the DSL router. I’m sure there is something simple and stupid I am doing wrong. Here are the details (some leading octets altered in the name of security):
DSL Modem LAN-side (gateway) address: 167.127.130.158
I have addresses 153-157
Here is my running-config. There is a PC sitting at 10.0.0.6 that can ping 10.0.0.1 and 167.127.130.157 but not the next hop (DSL router) at 167.127.130.158 or anything else on the internet. From the router I can ping 167.127.130.158 or anything else on the internet and I can also telnet to the router over the internet.
interface FastEthernet0/0
ip address 167.127.130.157 255.255.255.248
no ip mroute-cache
speed auto
full-duplex
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.0
no ip mroute-cache
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 167.127.130.158
ip route 10.0.0.0 255.255.255.0 FastEthernet0/0
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4